+ Reply to Thread
Results 1 to 9 of 9
  1. #1

    Join Date
    Nov 2011
    Posts
    7

    Straight talk BYOP problems... MM2

    I purchased a Micro sim card from Straight Talk and received it. I activated and transferred my old AT&T number, and once everything was finished... I get SIM not provisioned MM2 error. I have restarted my phone numerous times, I have updated my APN settings, nothing is helping. I have contacted ST via their forum as well as Facebook.....no response. Can anyone help me with this?


  2. #2

    Join Date
    Sep 2012
    Posts
    2

    Re: Straight talk BYOP problems... MM2

    phone info would be nice.

  3. #3

    Join Date
    Jan 2012
    Posts
    9

    Re: Straight talk BYOP problems... MM2

    sorry... new to this.. Pantech P9070

  4. #4

    Join Date
    Apr 2012
    Posts
    5

    Re: Straight talk BYOP problems... MM2

    sorry... new to this.. Pantech P9070
    Which carrier does this phone come from? Is it a Straight Talk phone, or purchased after being used with AT&T or T-Mobile?

  5. #5

    Join Date
    Apr 2012
    Posts
    4

    Re: Straight talk BYOP problems... MM2

    AT&T... I used it on AT&T, and then wanted to switch to straight talk. Bought micro sim, and installed, then activated, requested number to remain the same, and then turned it back on, got the message.

  6. #6

    Join Date
    May 2012
    Posts
    5

    Re: Straight talk BYOP problems... MM2

    Sounds like it might need an unlock. I'm no expert on Pantech, that is all I was able to find by Googling. You might try finding information on unlocking the phone first. Also, have you called customer support to make sure they actually activated the SIM?

  7. #7

    Join Date
    Jun 2012
    Posts
    3

    Re: Straight talk BYOP problems... MM2

    Thank you for your help. I was able to figure it out, the number I had requested was no longer active. Thanks again

  8. #8

    Join Date
    Jan 2012
    Posts
    3

    Re: Straight talk BYOP problems... MM2

    Thank you for your help. I was able to figure it out, the number I had requested was no longer active. Thanks again
    Looks like you forgot to port it before you tried to activate ST lol